我吃了一件宝石
并包含在我的Gemfile中的这一行:

宝石'功能',:git =>“https://github.com/< my-git-account>/feature.git”

但是Circe CI无法运行测试,而是生成此错误:

#!/ bin / bash -eo pipefail bundle install  - 来自http://rubygems.org / ........获取https://github.com/< my-git-帐户> / feature.git [!]加载`feature.gemspec`时出错:无法加载此类文件 -  rake / packageTask它会尝试需要一个相对路径吗?那是在Ruby 1.9中删除的。Bundler无法继续。#来自/home/circleci/ocm/vendor/bundle/ruby/2.3.0/bundler/gems/feature-15536​​c16af54/feature.gemspec:1#---------------------------------------->要求'rubygems / package_task'## ---------------------------------------用代码14退出

你知道这个问题可能是什么吗?

对你来说有更多问题:

  1. 这是在本地工作吗?
  2. 如果是的话,你正在运行哪个版本的Ruby?如果没有,你可能会有更好的运气,但报告int oc上游仓库。
  3. 您在CI中运行哪个容器图像?

您好,感谢您的答复。

如果我跑步捆绑安装-Path供应商/捆绑在本地,它不起作用...与CI相同的错误。

这是我们使用的东西:Circleci / Ruby:2.3-节点浏览器

这个主题在最后一次回复后90天自动关闭。不再允许新的回复。