今天我们使用刚刚发布的Xcode 9.0更新了我们的Xcode 9.0图像(构建版本9A235.)。

您可以通过在Circle.yml中指定Xcode 9.0来使用此图像:

机器:Xcode:版本:“9.0”

该图像目前仅包括iOS 11模拟器。我们正在努力为iOS 10模拟器添加支持。

1就像

请添加iOS 10模拟器。
无法在iOS 11上测试http://openradar.appspot.com/33563985.
谢谢!!!

@ igor-makarov谢谢你在这里的耐心。我们刚刚完成了包含iOS 10.3.1模拟器的图像的更新版本。

2喜欢

有没有人注意到构建时间随Xcode 9.0增加?我确实从swift 3.1变为swift 4.0和xcode 9.0,但没有别的东西真的改变了。使用Xcode 8.3我的构建在3-4分钟,但使用Xcode 9.0,它更像10-12分钟。我没有在我当地的MacBook Pro上看到这样的东西,但也许我错过了一些东西。

FYI我认为问题是Xcodebuild现在默认使用BitCode。这导致事情比以前更慢。如果其他人看到这个问题。

1就像

你好@Alexey.

我可以用circleci与xcode 9构建我的应用程序,但iTunes连接通知我使用Beta版本的Xcode构建。

1就像

嗨,不是nitpick,但似乎iOS 10 sims实际上是10.3而不是10.3.1 - 这与我的ci设置令人困惑......我错了吗?附件截图。

Apple刚刚制作了GM Build,9A235.,官方Xcode 9.0构建。

@Fnazarios.请检查您是否可以将Circleci的应用程序提交到iTunes立即连接?它现在应该很好9A235.是官方9.0版本。

Xcode:“9.0”酿造医生报告:

警告:您的Xcode(9.0)已过时。请更新到Xcode 9.0.1(或删除它)。

看到//www.drag240sx.com/gh/linuxbrew/homebrew-bio/48

指定Xcode:“9.0.1”产量

不支持指定的图像:Xcode:9.0.1

此页面表示Xcode:“9.0”应该是9.0.1:
//www.drag240sx.com/docs/1.0/build-image-macos/

有什么想法吗?谢谢,