嘿,伙计们!

对于使用CircleCI Remote Docker功能的用户(设置\u远程\u docker),Docker v19.03.8现已推出。

示例用法:

版本:2.1工作流:主要:作业:-构建作业:构建:docker:-映像:cimg/base:稳定步骤:-签出-设置\u远程\u docker:版本:19.03.8-运行:名称:“做所有事情!”命令:| docker构建-t我的组织/我的映像:我的标记。docker推送我的组织/我的图像

您可以在中找到所有可用的版本CircleCI文件.

4喜欢

嗨,谢谢你!

在我的config.yml中指定版本19.03.8实际上会安装19.03.9吗?

我一直在试着调试为什么我不能得到--输出使用docker的buildkit后端时要使用的参数。可以在我的笔记本电脑上使用,但不能在CircleCI上使用。在查看时,我注意到我的笔记本电脑使用的是19.03.8,而CircleCI使用的是19.03.9。对于我的问题来说,这可能是一个转移视线的问题(尽管我被可能存在的其他差异难倒了),但我想我还是提一下,以防它绊倒其他人。

干杯
卢克

在我的config.yml中指定版本19.03.8实际上会安装19.03.9吗?

看情况,没有看到你的配置我只能猜测。

我猜,你看的版本不对。如果您使用的是Docker executor,docker--版本仅返回您正在使用的Docker CLI的版本。这取决于您正在使用的映像。这篇文章是关于远程Docker的,它是您的Docker CLI通过网络连接到的引擎。每个版本都是不同的。

您可以通过运行docker版本(注意不要用破折号)。我希望这有帮助。

2喜欢

啊哈!这就解释了,谢谢。
你说得对-当我运行docker服务器时,它确实显示19.03.8docker版本
我猜这又回到了绘图板上,我想我的笔记本电脑设置有什么不同。干杯